WordPress 5.2 all the news

WordPress 5.2, Jaco in honor of another celebrated jazz bassist, Jaco Pastorius has just come out and is now available to update.

At first it can be updated, but, as it is not a security update, we can wait a few days, because several updates of plugins and themes will come out and 5.2.1 is already in preparation because there are several things that we wanted to add in this version but to meet the calendar they have decided to include them in the next one.

If we update, first backup, if you can do a clone or better staging, if you stay with us you already know that both things can be done with our Softaculous System, even update from Softaculous itself by making automatic previous copy before the update (all in one click) without the need to enter your WordPress administration, to your liking.

This update focuses on various tools already provided in the previous version and on fixing some bugs.

The health check of the site stands out, which appears in the tools menu, if we access we will have an analysis of the health status of our site, php version, update status of your plugins, themes, server status etc and some tips for to get better.

If all goes well we will get a screen like this

WordPress health status

If a report appears, it is usually easy to solve, a change in php, update plugins, themes, remove plugins and themes not in use, etc.

For example, changing to a higher php in Host-Fusion can be done in one click and if you need to activate any extension, in the same way through our control panels you can activate them in one click, all very simple.

Be careful with the cache, we have detected that sometimes the cache may be reflecting an erroneous data and give a false positive, but clearing the cache solves it.

Php protection

As I mentioned in previous posts, the php protection that came out in the previous version and now more work has been done on this version, is one of the most anticipated improvements by many, WordPress alerts you if something breaks when updating, it shows you a message on the screen and allows you to access the administration, something that was impossible before and that in the previous version did not work at all, now it seems that it does and it will be easier to solve possible incidents.

You can always use a backup, yes, but it is not the solution, I am more about learning how to solve something before throwing a backup, because that is taking a step back and not solving it and it will happen again, but this is my personal opinion :).

WordPress 5.2 will now check the version of your php with the minimum version of the plugins, in case they are not compatible it will not let you install it to avoid spoilage.

The minimum version that WordPress 5.2 supports is php 5.6.20, but it is also easy to solve if you need to upload from php.

As always improvements in the core, accessibility, privacy and other more technical features, but at first these are the news.

So I said, if you want to wait or make sure that your plugins and themes are compatible, check with their providers and make your backup before updating.

As always, a pleasure.